Incident history search unavailable

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 14 days ago. Sep 01, 2026 - 01:14 UTC

Investigating

We are investigating degraded performance for requests that use Composer 2.5. Users may see failed or retried requests in Page Renderer, Incident History, the Control Dashboard, and the Webhooks when Composer 2.5 is used. Other models are unaffected.
Posted 14 days ago. Sep 01, 2026 - 01:01 UTC
This incident affected: Page Renderer, Control Dashboard, Incident History, and Webhooks.