Incident history search unavailable

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 4 days ago. Sep 11, 2026 - 11:36 UTC

Investigating

All affected services are healthy.
Posted 4 days ago. Sep 11, 2026 - 11:08 UTC
This incident affected: Page Renderer, Control Dashboard, Incident History, and Webhooks.