Incident history search unavailable — Page Renderer, Incident History, Public API

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 12 days ago. Sep 02, 2026 - 16:10 UTC

Investigating

We are investigating a service degradation affecting Page Renderer, Incident History, and Public API where they are failing to start.
Posted 12 days ago. Sep 02, 2026 - 14:50 UTC
This incident affected: Page Renderer, Public API, and Incident History.