Incident history search unavailable

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 13 days ago. Sep 02, 2026 - 03:07 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 13 days ago. Sep 02, 2026 - 01:00 UTC

Investigating

We're currently investigating degraded performance affecting requests made with Composer 2.5 and Grok 4.6 Fast. While these models are in use, you may encounter failed or retried requests across Page Renderer, Incident History, the Control Dashboard, and the Webhooks. Other models are unaffected.
Posted 13 days ago. Sep 02, 2026 - 00:48 UTC
This incident affected: Page Renderer, Control Dashboard, Incident History, and Webhooks.