Degraded performance for Edge Cache routine triggers

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 11 days ago. Sep 04, 2026 - 00:42 UTC

Identified

Our email provider throttled the sending domain pending re-verification.
Posted 11 days ago. Sep 04, 2026 - 00:13 UTC

Investigating

We are investigating a service degradation affecting Edge Cache. Some trigger fires may be dropped.
Posted 11 days ago. Sep 03, 2026 - 23:42 UTC
This incident affected: Edge Cache.