Edge Cache computers unreachable for some users

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 7 days ago. Sep 07, 2026 - 21:37 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 7 days ago. Sep 07, 2026 - 20:41 UTC

Identified

Our email provider throttled the sending domain pending re-verification.
Posted 7 days ago. Sep 07, 2026 - 20:33 UTC

Investigating

We have identified an issue affecting Edge Cache. Some users may be unable to reach their Edge Cache computer, and Recover or Reset may fail. Your data is not affected. A fix is rolling out and we will post another update shortly.
Posted 7 days ago. Sep 07, 2026 - 20:32 UTC
This incident affected: Edge Cache.