Incident history search unavailable — Edge Cache

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 18 days ago. Aug 27, 2026 - 15:05 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 18 days ago. Aug 27, 2026 - 14:51 UTC

Investigating

We are investigating a service degradation affecting Edge Cache.
Posted 18 days ago. Aug 27, 2026 - 14:23 UTC
This incident affected: Edge Cache.