Uptime bars not updating

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 13 days ago. Sep 01, 2026 - 18:40 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 13 days ago. Sep 01, 2026 - 17:14 UTC

Investigating

Uptime bars now refresh on schedule. A stuck rollup job has been restarted.
Posted 13 days ago. Sep 01, 2026 - 16:42 UTC
This incident affected: Control Dashboard, Incident History, Webhooks, and Edge Cache.