Incident history search unavailable

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories. All services have returned to normal operation.
Posted 2 months ago. Jul 31, 2026 - 21:10 UTC

Update

Service is largely recovering. Some intermittent issues may remain as we finish restoring all systems. We are continuing to monitor.
Posted 2 months ago. Jul 31, 2026 - 20:56 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 2 months ago. Jul 31, 2026 - 20:37 UTC

Identified

We have identified the issue causing widespread failures across StatusX and are working on a fix. Users may continue to see errors in the Webhooks, Incident History, Page Renderer, and related services until the fix is fully rolled out.
Posted 2 months ago. Jul 31, 2026 - 20:34 UTC

Update

We are continuing to investigate a widespread issue affecting StatusX. Users may still see failures across the Webhooks, Incident History, Page Renderer, and related services. We will post another update shortly.
Posted 2 months ago. Jul 31, 2026 - 20:21 UTC

Investigating

We are investigating a widespread issue affecting StatusX. Users may see failures across the Webhooks, Incident History, Page Renderer, and related services.
Posted 2 months ago. Jul 31, 2026 - 19:50 UTC
This incident affected: Page Renderer, Public API, Control Dashboard, Incident History, Uptime Engine, and Webhooks.