Incident history search unavailable

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 11 days ago. Sep 03, 2026 - 17:07 UTC

Identified

Search is returning results again; we are monitoring for recurrence.
Posted 11 days ago. Sep 03, 2026 - 15:33 UTC

Investigating

We are investigating a service degradation affecting All Grok Models, Page Renderer, Incident History, Edge Cache and Public API
Posted 11 days ago. Sep 03, 2026 - 13:41 UTC
This incident affected: Page Renderer, Public API, Incident History, Webhooks, and Edge Cache.