Investigating page render latency

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 16 hours ago. Sep 14, 2026 - 09:07 UTC

Monitoring

A cold-start regression in the render function added latency on first loads. Fix deployed.
Posted 17 hours ago. Sep 14, 2026 - 08:15 UTC

Investigating

Dashboard load times are back to normal. An index was rebuilt to clear the regression..
Posted 17 hours ago. Sep 14, 2026 - 08:14 UTC
This incident affected: Page Renderer, Control Dashboard, Incident History, and Webhooks.