Degraded performance of Grok models

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 20 days ago. Aug 25, 2026 - 21:28 UTC

Monitoring

We are seeing signs of improvement and will continue to monitor for service restoration.
Posted 20 days ago. Aug 25, 2026 - 20:50 UTC

Investigating

We are investigating a service degradation affecting Grok models.
Posted 20 days ago. Aug 25, 2026 - 20:34 UTC
This incident affected: Page Renderer, Control Dashboard, Incident History, and Webhooks.