Incident history search unavailable — Public API and Incident History

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 4 days ago. Sep 10, 2026 - 17:32 UTC

Investigating

We are investigating a service degradation affecting Public API and Incident History. Incident History using "Privacy Mode" may experience errors and start delays. For Public API, Security Agents and PR Approval agents are impacted.
Posted 4 days ago. Sep 10, 2026 - 17:07 UTC
This incident affected: Public API and Incident History.