Degraded dashboard load times

Incident Report for StatusX

Resolved

We are investigating slow dashboard load times reported by tenants with large incident histories.
Posted 11 days ago. Sep 03, 2026 - 19:21 UTC

Monitoring

A missing index on the incidents table caused slow queries for tenants with long histories. Rollout in progress.
Posted 11 days ago. Sep 03, 2026 - 18:57 UTC

Investigating

Dashboard load times are back to normal. An index was rebuilt to clear the regression.
Posted 11 days ago. Sep 03, 2026 - 17:42 UTC
This incident affected: Control Dashboard, Incident History, Webhooks, and Edge Cache.